Groesbeek, view of the 'National Liberation Museum 1944-1945' in Groesbeek. © Ton Kersten
Fork me on GitHub

(Not) building git RPM's

2010-03-02 (42) by Ton Kersten, tagged as old

Today I saw that git version 1.7.0.1 was out and while I missed out on 1.7.0 I decided it was time for some RPM's again.

Well, NOT. The sources built like a charm and I'm using 1.7.0.1 now for the daily work.

The big problem is the documentation, as always. When I want to build the docs, the build proces fails with some strange table-header and table-definition error, that even Google has never heard off.

All I know now that it has something to do with asciidoc being the wrong version. It does build on Debian Lenny and Ubuntu 9.10 though.

Update:

It took some time, but I did get it working. For some way or another after a make clean it all worked. So I repacked the sources and built the RPM.

You will know. It's in the files section.