Groesbeek, view of the 'National Liberation Museum 1944-1945' in Groesbeek. © Ton Kersten
Fork me on GitHub

It's broken again

2009-11-20 (35) by Ton Kersten, tagged as old

A new git (1.6.5.3) arrived and I thought I should create RPM's for this again.

This turned out to be rather tedious and frustrating.

Running

rpmbuild -ba git.spec

as usual gave me this error

I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd
/home/tonk/rpmbuild/BUILD/git-1.6.5.2/Documentation/git-add.xml:2: warning: \
failed to load external entity "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd"
Hmm, never seen that one before. Digging around in the Makefile and adding a lot of echo's to
display some debugging info, I found it.

I recently upgraded to CentOS 5.4 and now it turns out that CentOS breaks things. In the file /etc/asciidoc/docbook.conf` it says:

... and that's wrong. There is no file for version 4.5. I didn't feel like finding out how to repair all these packages and the "dependency hell" involved. I just didn't have the stomach for it, right now (not at 01:30 AM).

So, no nice repairs, but I just changed the above line to:

(See the subtle difference between the two, 4.5 versus 4.2)

Now it all works, although I still do not know which package really breaks things.

If I ever find out I will let you know.

Comments